Lorsque l'on dessine un rectangle avec la commande polyligne, dans certains cas après l'utilisation de la fonction "Supprimer les doublons", le rectangle change de forme.

J'ai remarqué cela lorsque un rectangle était dessiné avec la commande polyligne en partant du coin en bas à droite et qu'on le dessinait en sens anti horaire.

Sur la longueur du haut et du bas ajoutez un sommet au milieu de la ligne.

Visuellement cela fait un rectangle mais qui est composé de 6 sommets.

Si vous utilisez à ce moment-là la commande "Supprimer les doublons" votre rectangle se transforme en trapèze.

Pour que ce soit plus clair essayez avec la pièce jointe.

Testé avec AutoCAD LT 2013

Vues : 141

Pièces jointes :

Y répondre

Réponses à cette discussion

Salut Eric, c'est vrai que c'est surprenant.

Toutefois, en décochant  l'option "Optimiser les segments au sein des polylignes", le rectangle ne change pas de forme.

Ce qui est étrange, c'est que le rectangle change de forme avec la commande "Supprimer les doublons" ou "Overkill" (si l'option "Optimiser les segments au sein des polylignes" est cochée) avec le second sommet qui disparaît. J'ai fait le test en créant un rectangle dans différents sens et en ajoutant ensuite un sommet sur chacune des longueur et c'est toujours le second sommet qui est supprimé.

Testé sur AutoCAD Architecture 2013

[Edit] J'ai fais le test sur AA 2012 et c'est pareil. Toutefois, j'ai aussi fait le test avec la version 2011 et le problème ne se pose pas. ce sont les sommets des milieux qui sont supprimés.

Merci Steven pour tes tests sur les différentes versions.

Toutefois, j'ai aussi fait le test avec la version 2011 et le problème ne se pose pas.

Donc ça a fonctionné jusqu'à la version 2011.

ce sont les sommets des milieux qui sont supprimés.

Normalement c'est ce que ça devrait faire.

Donc c'est bien un bug introduit avec la version 2012.

 

Est ce quelqu'un a trouvé une solution ?

Cela fait maintenant 3 versions que ce bug nous pourrit la vie au boulot.

Nous utilisons beaucoup cette commande et exclusivement sur de la polyligne, je vous laisse imaginer la catastrophe. La seule solution que nous avons trouvé à l'heure actuelle est de garder une version 2011 sur un des postes, mais ce n'est une solution durable :(

Bonjour,

Je viens de faire un signalement à Autodesk.

On va voir si ça bouge.

Merci pour ton aide.

Mais j'ai l'impression que la réactivité n'est pas le point fort du monde Autodesk.

Enfin à part les revendeurs et formateurs, ce qui permet à Autodesk de garder ces clients.

RSS

Membres

Bibliothèque TraceParts - Fichiers 2D & 3D GRATUITS

© 2014   Créé par AUGIfr

Badges  |  Signaler un problème  |  Conditions d'utilisation